System requirements for Sahana to be installed

Apache HTTP Server

Apache HTTP is an open source web server. There are many versions of Apache web server for different operating systems. You can download Apache from http://httpd.apache.org/download.cgi
version 1.3 or later

MySQL Database server

MySQL is an open source database engine Sahana uses for storing its information.
You can download mysql here http://dev.mysql.com/downloads/mysql/5.0.html
version 4.1 or later

If you want to manage Sahana MySQL database, you can do it either by using command line interface of graphical MySQL manager like MySQL Administrator or MySQL Query Browser. Go to MySQL GUI tools http://dev.mysql.com/downloads/gui-tools/5.0.html

PHP parsing engine

Sahana is based on PHP scripting language. Prior to install Sahana on your computer, you have to install PHP parse engine.
You can download php from http://www.php.net/downloads.php
version 5.0 or later with latest php5-gd lib are recommended.


You can either install Apache HTTP server, MySQL and PHP as three independent packages or as a single bundled package as WAMP / LAMP. If you wish to install bundled WAMP / LAMP you can download it from http://www.wampserver.com/en/download.php

GIS requirements

The GIS functionality has a few requirements of the base system above a non-GIS Sahana instance:

  • Curl module for PHP
  • a fairly high memory_limit in php.ini to handle large KMZ files (suggest 32M)

Navigation
  • Navigate